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About this tutorial
This two-part tutorial will get you started with CorelWEB.MOVE. In part A, you'll use a prop and an actor from 
WEB.MOVE's libraries to create a simple animation, then publish the animation in Web-ready form. In part B, 
you'll create an actor of your own, place it in an animation, and make it act. Complete both parts of the tutorial, 
and you'll be well on your way to mastering the basics needed to create any animation in WEB.MOVE.
What you'll do

Before you begin, display the Help and WEB.MOVE windows side by side. That way you can read the tutorial in 
the Help window as you create your animation in the WEB.MOVE window.
To display the Help and WEB.MOVE windows side by side

a. Resize the WEB.MOVE window so it takes up most of the left side of your computer screen.
b. Resize the Help window so it takes up the remaining part of the screen -- just enough so you can read the 

Tutorial instructions.
c. Click Options, Keep Help on Top, and then choose On Top. A check mark beside the On Top option ensures that 

the help will remain on screen.

d. When you're ready to start creating your animation, click the forward button  at the top of the screen
to go to step 1.



A. Create an animation
In eight simple steps, and not many more minutes, this part of the tutorial will help you create your first 
WEB.MOVE animation.
A.1. Display the animation window
What you'll do

If you've been using WEB.MOVE, then the window where you'll create your animation is already displayed, along 
with the Toolbox and Control Panel. But if you've just started WEB.MOVE, then you need to display the animation 
window before getting down to work.
To display the animation window

a. From the File menu, select New.
The animation window is now displayed in the WEB.MOVE screen. All of the menus except the Arrange menu 
are active at the top of the screen. The Toolbox is displayed at the upper left. And the Control Panel is 
displayed at the bottom of the screen. (If it's not, choose View, Control Panel to display it.)
You're ready to create an animation.



A.2. Place a background
What you'll do

In this step, you'll place a background against which your animation's action will take place. The background is in
the library file UNDERSEA 1. Like all library files, it's compressed, so you'll use WEB.MOVE's Library Roll-up to find
and place it.
To place a background

a. Place the CorelWEB.GRAPHICS CD in your CD-ROM drive.

b. From the Tools menu, select Library Roll-up. (Or, click  in the Control Panel at the bottom of the screen.)
The Open Library dialog is displayed. (If you've recently used a library, then the Library Roll-up is displayed

instead. If that's the case, click  to display the roll-up's menu, then choose Open Library.)
c. In the drives window, select the WEB.GRAPHICS CD. Next, select Webmove\Library.

d. In the File Name list, click props4.mlb, then click OK.
The name props4.mlb appears at the top of the Library Roll-up, and the first image in the library is displayed.

e. Use the Library Roll-up's scroll bar to scroll to UNDERSEA 1.
f. When UNDERSEA 1 is displayed, click the Place button at the bottom of the Library Roll-up. Select resize the 

prop to fit in frame and click OK. 
UNDERSEA 1 has been placed in the animation window, giving you a background for your animation. Next, 
you'll place an actor in the animation.



A.3. Place an actor
What you'll do

To provide an animation with action, you need actors. In this step, you'll place the library actor snorkler 1 in your 
animation.
To place a library actor

a. In the Library Roll-up window, click  to display the menu, then select Open Library.
b. From the File Name list in the Open Library dialog, choose undersea.mlb, then click OK.

The undersea.mlb library is displayed in the Roll-up.
c. Scroll through the Library Roll-up, one image at a time, until the file snorkler 1 is displayed, then click 
Place. Select resize the actor to fit in frame and click OK.

You've placed Snorkler 1 in the center of the animation window. Next, you'll move it to the upper right of 
the window.

d. Click on the snorkler to select it.
When the snorkler is selected, a dotted line appears around it, and the message `Actor: snorkler 1' is 
displayed in the Control Panel. If    Prop: UNDERSEA 1 is displayed instead, you've selected the background by 
mistake. If that's the case, try again to select the actor.

e. Once snorkler 1 is selected, drag it out of the upper right of the animation window, so only the beam of its 
flashlight is visible in the upper right corner of the window.
You've placed the actor snorkler 1 where you want it in the animation window. Next, you'll create a path for the
actor to follow through your animation.



A.4. Create a path
What you'll do

You want snorkler 1 to enter your animation at the right, swim through the animation window, then exit at the 
left. To make that happen, you need to create a path for snorkler 1 to follow. That's what you'll do now.
To create a path for the actor

a. If snorkler 1 isn't already selected, select it.

b. To activate the path tool, click  in the tool box.
The Path Edit dialog box is displayed, the cursor has changed to a  and a single node is displayed for 

snorkler 1. You'll use the path tool to click a path through the animation window for snorkler 1.
c. In the Path Edit dialog box, check Allow Adding Points.
d. Use the cursor and the left mouse button to click along the path that you want snorkler 1 to follow through 
your animation. Start at the right, and end at the left of the animation window.

As you created a path for snorkler 1, every click you made placed one node in the path. Each of these nodes 
represents snorkler 1's position for one frame in the animation. In the next step, you'll edit the path to make 
sure that your actor travels smoothly through the animation.



A.5. Edit the path
What you'll do

In this step, you'll fine tune snorkler 1's path through the animation, so he swims smoothly and evenly when you 
play the animation.
To edit the actor's path

a. With the node edit tool still active, and snorkler 1's path displayed, drag the right-most node out of the 
animation window to the right, far enough that the beam from the flashlight is not visible in the animation 
window.
When you've done this, snorkler 1 will not be visible, but the selection frame around it will be.

b. Now drag the left-most node out of the animation window to the left, so snorkler 1 will be out of the animation 
window completely when it reaches the end of the path.
You've modified snorkler 1's path so he will enter and exit the animation when it is played. Next, because the 
greater the number of nodes in a path the smoother the action, you'll add nodes and distribute them evenly 
along the path.

c. In the Path Edit Roll-up, click . Then, in the Scale Path dialog, change the Desired entry to 50 and click 
OK.

As you can see, snorkler 1's path now has 50 nodes in it.

d. To smooth the path, and distribute the nodes evenly along the path, click , then click 

.

e. Deactivate the node tool by clicking  in the toolbar.
You've modified snorkler 1's path so he will enter the animation, swim smoothly through it, then exit. Next, 

you'll modify his Timeline to specify when he will enter and exit the animation window.



A.6. Edit the timeline
What you'll do

Every actor and prop has a timeline that determines when it enters and exits an animation. In this step, you'll 
make snorkler 1 enter your animation at frame 25, and exit at frame 75.
To edit the timeline

a. From the Tools menu, choose Timelines Roll-up, or click  in the Control Panel at the bottom of the screen.
The Timelines Roll-up is displayed. In addition to changing the timeline for an actor or prop, you can use 

the Timeline window to select an actor or prop. This is especially useful if the actor is out of the animation window, 
or if your prop is used as a background file.
b. To display Timeline information for the animation, click  in the upper right of the Timeline Roll-up.

As you can see, snorkler 1 and UNDERSEA both enter the animation at frame 0 and exit at frame 100. (The 
default number of frames for an animation is 100.) You'll change the entrance and exit frames for snorkler 1 to
25 and 75.

c. To set snorkler 1's entrance frame to 25, place the cursor over the left end of snorkler 1's timeline until it 
becomes a , then hold down the left mouse button, drag the line end to 25, and release the mouse button.

d. To set the exit frame to 75, place the cursor over the right end of snorkler 1's timeline until it becomes a
, then drag it to 75.

e. To hide the Timeline Roll-up, click  in the upper right corner of the roll-up.
You've arranged snorkler 1's entrance and exit, and you're ready to play your animation.



A.7. Play the animation
What you'll do

The Control Panel at the bottom of the WEB.MOVE screen is like a video control panel. You can use it to play an 
animation, rewind it, move it forward or backward one frame at a time, and view information about your 
animation and its actors. In this step, you'll use it to play the animation you've created.
To play the animation

a. To play the animation, click  in the upper right of the video control panel.
When the animation plays, snorkler 1 enters the animation window at frame 25, swims through the 

window, and exits at frame 75. If the  is selected, the animation will continue to play until you stop it.

b. When you're ready to stop the animation, click  in the video Control Panel.
c. If you want to save your animation so you can play it or work on it later, choose File, Save. Then, in the 
Save Animation As dialog, select the directory where you want your animation saved, enter a name for the 
animation in the File Name field, and click OK.

Next, so you'll be able to use your animation in a Web page, you'll publish it as a Java Applet.



A.8. Publish the animation
What you'll do

Before you can upload an animation to your Web site, you must publish the animation in a form that can be used
on the Internet.
To publish the animation

a. From the File menu, choose Save As, name the move (.cmv) file and save it in a directory of your choice. 
(Note: this step was necessary to allow you to edit your animation in the future.)

b. Next, from the File menu, choose Publish, to Java Applet.
c. Use the Directories area of the Publish To Java Applet dialog to specify the directory where you want the 

animation published as a Java Applet.
d. In the File Name field, enter a name for the Java Applet, then click OK.

You've now published your animation as an HTML file that contains a Java Applet. To incorporate this Java 
Applet into your Web page, open CorelWEB.DESIGNER and click Insert, HTML file. Next, locate the HTML file 
that you just created and click Open. The first screen of the Java Applet is now displayed in 
CorelWEB.DESIGNER. (The animation will run when viewed in any Java supporting browser.)
Note: If you had launched WEB.MOVE from within WEB.DESIGNER, you would choose File, Publish to 
WEB.DESIGNER to automatically add the Java Applet to your open Web page.

Where to now?

You've created a WEB.MOVE animation. Although it's a simple one, you can use the same steps to create any 
animation, using the ready-made actors, props, and sounds that come with WEB.MOVE. If you want to learn how 
to create your own actors, go on to part B of the tutorial.

 



B. Create an actor
In this part of the tutorial, you'll create a simple actor in CorelWEB.DRAW, then try it out in WEB.MOVE.
B.1. Start a new animation
What you'll do

If you've just finished Part A of the tutorial, the animation you created is still displayed. In this step, you'll start a 
new animation, then launch CorelWEB.DRAW, where you'll create an actor.
To begin creating your own actor 

a. From the File menu, choose New.
An empty animation window is displayed in the WEB.MOVE screen.

b. To display the New Actor dialog, click  in the tool bar at the top left of the WEB.MOVE screen.
When you perform the next step, the WEB.DRAW window will probably cover this Help window. When that 

happens, resize the WEB.DRAW window so the Help window is visible again.
c. In the New Actor dialog's Object Type window, click CorelWEB.DRAW 1.0 Graphic, then click OK.

CorelWEB.DRAW has been launched, with the Cel Select Roll-up displayed. In the next step, you'll begin to 
create your actor.



B.2. Draw an actor
What you'll do

Any object can be an actor, and the actors you create in WEB.DRAW can be as sophisticated as your skill and 
imagination allow. Since our purpose right now is just to learn the process of creating an actor, let's keep it 
simple. For your actor, you'll draw a simple rectangle, fill it with color, and make it spin.
To draw a simple rectangle

a. Click  in the tool bar at the left of the WEB.DRAW screen.
b. Draw a rectangle in the middle of the screen.
c. If the Color Palette isn't already displayed at the bottom of the screen, choose View, Color Palette, Custom 
Colors.
d. To fill the rectangle with color, click a color in the color palette at the bottom of the screen.

You've created an actor. In the next step, you'll give it action.



B.3. Create positions for the actor
What you'll do

To act, an actor must move. In an animation, the illusion of movement is created by placing an actor in a 
different position in successive cels of the animation. In this step and the next, you'll create a series of different 
positions for your actor, so it appears to move when you use it in an animation.
To create a series of positions for your actor

a. In the Cel Select Roll-up, click the To Next check box so an x is displayed in it.
Now, when you make changes, the changed actor will appear in the next Cel of the animation rather than in 
the same Cel. This will create the illusion of movement when the Cels that make up the animation are played.

b. From the Effects menu, choose Transform Roll-up.
The Transform Roll-up is displayed.

c. Pull the Transform Roll-up away from the Cel Select Roll-up, so you can see both roll-ups clearly.

d. To activate the rotation portion of the Transform Roll-up, click .
e. In the Transform Roll-up's Angle of Rotation field, enter 10.

Now, when you apply a rotation to your actor, the actor will rotate 10 degrees. At the same time, because 
To Next is activated in the Cel Select Roll-up, the rotation will be applied to the actor in Cel 2 rather than Cel 1.
f. In the Transform Roll-up, click Apply.

The rectangle has rotated 10 degrees, and Cel 2 has been created in the Cel Select Roll-up. In the next 
step, you'll continue modifying your actor.



B.4. Complete the actor
What you'll do

In this step, you'll continue what you started in step 3. You'll apply the 10-degree rotation to your actor another 
16 times. The result, when you play your animation, will be a spinning rectangle. 
To finish creating your actor

a. With the actor still selected, click the Transform Roll-up's Apply button to create another position for your actor.
(Note: It's optional, but if you want your rectangle to change color when it spins, deactivate the To Next check 
box before performing the next step, apply a different color to the rectangle, then reactivate the To Next check
box before applying the rotation again. Do this for each of the 15 additional rotations that follow, and your 
spinning rectangle will change color as it spins.)

b. Repeat step a, above, 15 times, until the entry in the Cel Select Roll-up is Cel 18. If you want the color to 
change as the actor spins, remember to change the color before each rotation, activating and deactivating the
To Next check box each time, as described above.
Now that you've finished, the rectangle has almost completed a 180-degree rotation, and has a different 
position for each of eighteen different cels in the animation.

c. To leave WEB.DRAW, and return to WEB.MOVE, choose File, Exit & Return to UNTITLED.CMV.
The CorelWEB.DRAW dialog is displayed.

d. To update the actor you've created, click Yes in the CorelWEB.DRAW dialog.
WEB.DRAW saves each of the actor's eighteen different positions, or cels, and returns you to WEB.MOVE, 
where the actor is displayed in the animation window. In the next step, you'll make your actor act.



B.5. Play the actor
What you'll do

You've created an 18-cel actor and placed it in the animation window. Now, when you play the animation, your 
actor will repeatedly move through the series of 18 different positions you've created. And it will repeat those 18 
cels throughout the 100 frames of your animation. The result will be a spinning rectangle, which may or may not 
change color, depending on how you've created it.
To play your actor

a. First, to confirm that the actor does have 18 cels, click the actor to select it.
The message `Actor, contains 18 cels' is displayed in the Control Panel, confirming that the actor is made up of
18 different cels.

b. To make the actor act, click  in the Control Panel.
Your actor's act consists of a smooth, continuous rotation that is repeated until you stop the animation.

c. When you're ready to stop the animation, click .
You've created a simple actor in WEB.DRAW, placed it in an animation in WEB.MOVE, and made it act. And 

you now have just about all the skills you need to create animations in WEB.MOVE. In the final step that follows, 
we'll give you some ideas for continuing your quest to master WEB.MOVE.



Where to next?
Congratulations on completing your first WEB.MOVE animation, and creating your first actor! True, the animation 
and actor are both simple. But you can repeat the steps you followed to create any animation, and any actor. So 
take what you've learned, add your artistic talent and creativity, and get to work producing exciting animations 
that will add eye-catching life to your Web site. If you need assistance, refer to the other parts of WEB.MOVE's 
extensive online Help system.
If you've had enough for now, choose File, Exit to leave WEB.MOVE. But if you're eager for further exploration, try
the following suggestions.
Suggestions for further exploration

a. Return to the animation you created in part A, and add more actors from the undersea.mlb library. Make a crab
or crayfish scuttle across your animation, or have some fish swim through it. You can add to the animation 
using the steps you already followed. Then use the Timelines Roll-up to orchestrate your actors' entrances and 
exits.

b. Do you have a sound card and speakers? Then give your animation a soundtrack. Return to undersea.mlb, find

subping.wav, and place it in your animation. Make sure the Control Panel's  button is activated, then play 
the animation again -- this time with sound!

c. Create your own actor in WEB.DRAW; something more interesting than a spinning rectangle. Create it from 
scratch, or import a file and modify it, creating different positions for different cels. Then place it in WEB.MOVE,
add an animation and play it.

The best way to master WEB.MOVE is to experiment. So follow your own ideas. Try different things. Before long 
you'll be well on your way to becoming a WEB.MOVE expert. And chances are you'll have fun getting there!




